ARP-Poisoning Lab - arpspoof is not working properly?

I am doing ARP-Poisoning Lab and the arpspoof tool doesnt seem to be working properly even after i had applied all the steps (for solution).
Any ideas?

Thats quite surprising, it did work for me recently though. I did use directly arpspoof command available in Kali with no other external packages.
Can you try updating the package/distribution ?

My command:
image - It did work

Also, I see some sites mentioning the issue with Kali rolling, you could try installing alternative from github

  1. GitHub - byt3bl33d3r/arpspoof: Python clone of arpspoof that can poison hosts via arp-requests as well as arp-replies
  2. Or if none works, then you can try with Bettercap/Ettercap

I tried github as suggested and the response is as shown

Do you have arpspoof installed by default? Because my kali isnt

I had tried to install it separately and couldn’t get it to work, so I just installed the whole dsniff kit, which includes arpspoof.


@Studentz Yes do I have it installed by default in the Kali distribution.

I guess some modules/libraries in python file are missing, can u check which version of python you are running (python --version) and select the different version before the command. (Start the command with python2,python2.7 or python3).

Else, try installing pip.

  1. Sudo apt update
  2. apt install python3-pip
  3. pip install arpspoof
    If required:- To upgrade: python -m pip install --upgrade pip

If not resolved, then i guess u can try using bettercap/ettercap

I did this also but to no avail. Probably missing some syntax. Mind sharing what command do you use to make dsniff work?

After Installing dsniff, the aprspoof command from the solution works without any additional steps.

That was it. Just installed on my host machine to double check. You do need to run arpspoof with sudo.

Seems like the ettercap tool does wonder. I do have pip installed but quite outdated. Still missing those files and cant seem to make arpspoof to work

I did this but seems like some of these file are still missing


i have no idea where and how to get those files nor how to fix it

Awesome…!! Yes tried with older version of Kali, having same issues infact my updates (apt update)are not rolling into the Kali-VM - I guess libraries and distribution packages must have outdated.
Which version of Kali are you trying this from ?

Im currently using 2021.1. Is it same as the ones you are trying with?

Did you try with python2 ? sudo python2
Also make sure Scapy is installed.

git clone
cd scapy
sudo python install

I’m using the same version.

I just thought of something. After you installed using “sudo apt install dsniff” did you still try to run it with “python”? If so, try it with just straight “sudo arpspoof -i …”.

hey, I tried these but it doesnt seem to be working. Thank you for the suggestion :slightly_smiling_face:

I did this but the same thing pop out. Seems like I was missing some wheels for python

Can share the screenshots here?, really interested to see the errors.

Also try to shoot the following commands to update and fix any missing packages.

sudo apt update -y && apt upgrade -y && apt dist-upgrade
#Use  --fix-missing in case of any errors after the update.

Then try to install the dnsiff,

sudo apt install -y dsniff

Make sure you disable your host firewall/internet security software while performing this. Many antivirus vendors blocks these tools and often results in broken installations.

Hey thanks, will be trying this. Also if my firewall/internet security block these tools will there be any popup shown? or my antivirus simply blocks the tools?