Dhcp

Hello ,
I have a DHCP server connected to a DHCP Relay. The DHCP Relay is connected to two different DHCP Clients (Relay and both clients are in a full mesh).

My DHCP clients are receiving the IP address only on the interfaces facing the DHCP Relay.
These two DHCP clients are not receiving the IP addresses on the interfaces that face each other (DHCP Client-DHCP Client). I am not sure why…

DHCP Server
==> I have several pools of IP address referencing the Gateway to the DHCP Relay.
==> I have a loopback interface.
==> I have EIGRP as the routing protocol.
==> I have some DHCP Excluded-addresses.

DHCP Relay
==> I configured the IP addresses manually
==> The command ip helper-address referencing the loopback of my DHCP server is configured under each interface
==> I have EIGRP as the routing protocol

DHCP Clients 1 & 2
==> I configured the command ip address dhcp under each interface
==> I have EIGRP as the routing protocol

Issue: Only the interfaces on my DHCP clients that face each other are not allocated an IP address from the DHCP server. How can we make that happening?

Thanks

i`m not sure if i understand your issue good. are you using IPv4 or IPv6 addresses ? what is the IP addresses assigned to the relay agent ? are your L2 information is UP and working correctly ?what is the topology looks like ?

Thank you for getting back to me about my issue.
I am using IPv4 addresses and attached the topology I am using…

I have full IP connectivity between the DHCP server, the DHCP Relay, and the interfaces on the DHCP Clients that are facing the DHCP Relay.

However, my issue is that I have no IP addresses being allocated from one of the pools on my DHCP server to the interfaces Gi0/1 on my DHCP Clients (these are the interfaces on the DHCP Clients that are facing each other).

The configuration I used is below as well as the output on my DHCP Clients.

topology

DHCP Server

ip dhcp excluded-address 1.1.1.252
ip dhcp excluded-address 1.1.2.40
ip dhcp excluded-address 1.1.3.40
!
ip dhcp pool INTERNAL1
network 1.1.1.0 255.255.255.0
default-router 1.1.1.252 <== This is the Relay Gateway
dns-server 150.28.1.1
!
ip dhcp pool INTERNAL2
network 1.1.2.0 255.255.255.0
default-router 1.1.1.252 <== This is the Relay Gateway
dns-server 150.28.1.1
!
ip dhcp pool INTERNAL3
network 1.1.3.0 255.255.255.0
default-router 1.1.1.252 <== This is the Relay Gateway
dns-server 150.28.1.1
!
ip dhcp pool R2_CLIENT_POOL
host 1.1.4.10 255.255.255.0
!
ip dhcp pool INTERNAL4
network 1.1.4.0 255.255.255.0
default-router 1.1.1.252 <== This is the Relay Gateway
dns-server 150.28.1.1
!
interface Loopback0
ip address 5.5.5.5 255.255.255.255
!
interface GigabitEthernet0/1
ip address 1.1.1.253 255.255.255.0
!
router eigrp 1
network 0.0.0.0
eigrp router-id 11.11.11.11


Relay
interface GigabitEthernet0/0
ip address 1.1.2.40 255.255.255.0
ip helper-address 5.5.5.5

interface GigabitEthernet0/1
ip address 1.1.1.252 255.255.255.0

interface GigabitEthernet0/2
ip address 1.1.3.40 255.255.255.0
ip helper-address 5.5.5.5
!
router eigrp 1
network 0.0.0.0


Client R2
interface GigabitEthernet0/0
ip address dhcp
interface GigabitEthernet0/1
ip address dhcp
!
router eigrp 1
network 0.0.0.0


Client R3
interface GigabitEthernet0/1
ip address dhcp
interface GigabitEthernet0/2
ip address dhcp
!
router eigrp 1
network 0.0.0.0


R3(config)#do sh ip int brief
Interface IP-Address OK? Method Status Protocol
GigabitEthernet0/0 unassigned YES DHCP up up
GigabitEthernet0/1 unassigned YES DHCP up up
GigabitEthernet0/2 1.1.3.2 YES DHCP up up
GigabitEthernet0/3 unassigned YES unset administratively down down

R2(config)#do sh ip int brief
Interface IP-Address OK? Method Status Protocol
GigabitEthernet0/0 1.1.2.1 YES DHCP up up
GigabitEthernet0/1 unassigned YES DHCP up up
GigabitEthernet0/2 unassigned YES DHCP up up

The default router option isn’t a relay, it’s the gateway that DHCP pool should use.

You need to fix your DHCP pools to use the correct gateways. You also need helper addresses on DHCP Relay’s G0/0 and G0/2 interfaces.

1 Like

Yes, you are right. The default router configured in my pools is the IP address of the next router (gateway). The next router has its interfaces with IP address being configured manually. Each of the interfaces facing to the DHCP clients must have an IP address configured manually + the IP helper address (that is a loopback on my DHCP server).

The DHCP clients interfaces just need to be configured with the ip address dhcp. The DHCP server will then allocate an IP address from the relevant pool to these DHCP clients.

Then, the process repeats itself over and over.
The rule can be summarized “one side is manually configured with an IP and the other side is assigned via DHCP”. There is a routing protocol configured on each router to provide a route back to the DHCP server.