eWPT Introduction Lab

Hello,
I have an issue with the Introduction Lab of the eWPT path. I contacted 'support@ine.com but their solutions didn’t work.


I noticed that the line before the ‘Initialization Sequence Completed’, I am supposed to see ‘broacast + [IP]’ (after tap0). I don’t know why it’s not here.

When I click on the link for the lab environment at http://info.introduction.site/ I am redirected to a Chinese site.

'support@ine.com told me:
First, could you please add ‘nameserver <DNS_SERVER_LAB_IP> as the first entry in the file /ect/resolv.conf
/etc/resolv.conf file changes can be lost due to a connection drop, please double check if it’s the still the same.
Secondly, if the above doesn’t work, flush DNS Cache from your browser. If using Firefox, type “about:networking#dns” then Clear DNS Cache. If using Chrome, type “chrome://net-internals/#dns” then Clear Host Cache
Finally, please set the DNS to 10.100.13.37

I have Kali Linux on Debian, and I have Firefox. I followed these instructions but I didn’t change anything. If somebody know what my problem is, I would be very grateful!

If you don’t configure things properly, you won’t be able to hit the websites in the labs.

1 Like

you have to set the dns in /etc/resolv.conf to 10.100.13.37

so nameserver 10.100.13.37

Yes I already did that

hmm weird, can you show me a screenshot of your /etc/resolv.conf

1 Like

Hey maybe you can give this a try, let me know if it works, also remove that blank line on line 5

search home
nameserver 10.100.13.37
nameserver 192.168.1.1

@lilith4u2-36cdb7de2b - did you find the solution to this problem?
I have the exact same situation as you.

so to recap:

tux@tuxPC:~$ openvpn introduction-labs.ovpn
Mon Oct 11 11:54:45 2021 OpenVPN 2.4.4 x86_64-pc-linux-gnu [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [PKCS11] [MH/PKTINFO] [AEAD] built on Apr 27 2021
Mon Oct 11 11:54:45 2021 library versions: OpenSSL 1.1.1  11 Sep 2018, LZO 2.08
Enter Auth Username: TQpRpOAJvqxgVO
Enter Auth Password: **************
Mon Oct 11 11:54:53 2021 TCP/UDP: Preserving recently used remote address: [AF_INET]209.133.218.11:42677
Mon Oct 11 11:54:53 2021 Attempting to establish TCP connection with [AF_INET]209.133.218.11:42677 [nonblock]
Mon Oct 11 11:54:54 2021 TCP connection established with [AF_INET]209.133.218.11:42677
Mon Oct 11 11:54:54 2021 TCP_CLIENT link local: (not bound)
Mon Oct 11 11:54:54 2021 TCP_CLIENT link remote: [AF_INET]209.133.218.11:42677
Mon Oct 11 11:54:55 2021 [Hera Openvpn Cluster] Peer Connection Initiated with [AF_INET]209.133.218.11:42677
Mon Oct 11 11:54:57 2021 TUN/TAP device tap0 opened
Mon Oct 11 11:54:57 2021 do_ifconfig, tt->did_ifconfig_ipv6_setup=0
Mon Oct 11 11:54:57 2021 /sbin/ip link set dev tap0 up mtu 1500
Mon Oct 11 11:54:57 2021 /sbin/ip addr add dev tap0 10.100.13.200/24 broadcast 10.100.13.255
Mon Oct 11 11:54:57 2021 Initialization Sequence Completed

then I go sudo nano /etc/resolv.conf and add:

nameserver 10.100.13.37
search home
domain introduction.site
search info.introduction.site

I tried multiple combinations and nothing worked… :confused:

Hello, yes I resolved my problem, thanks for the responses.
If there is the Initialization Sequence Completed at the end, it’s a good sign.
Have you checked your proxy? When I am working with Burp Suite, I sometimes forgot to disable the proxy.
Do you check with cat /etc/resolv.conf afterwards ? I use mousepad instead.