EXAM - Meterpreter session does not show up via autorouted listeners


I am currently performing the eCPPTv2 exam. At this moment I already exploited the first machine but I’m facing connectivity issues that I think are on environment side. Specifically. After getting a meterpreter shell of this first machine on my computer, I manually added on the first exploited machine the routes to reach the hosts in the internal network (even though it was already reachable) and I added routes inside my Metasploit to redirect all the traffic to first exploited machine and the internal network via meterpreter session. It worked fine since I mapped the entire internal network and I could execute commands on one of the host by exploiting a known vulnerability. When I try to get a meterpreter shell from this internal host, though, I have to switch on a listener on first exploited machine, since my host is unreachable from the inside. When I do it and I try to exploit the known vulnerability to get the meterpreter session of the internal host, I get the message stating that the listener on the first exploited machine has been raised up via meterpreter session 1 but at the end I never get the meterpreter session. I also tried before to implement it manually via portfwd inside the meterpreter session but it does not work. It seems like that the listener is not actually switched on the first exploited machine, verified also via netstat when such listener was supposed to be up.

Did it happen to someone of you in the past? Could it be a exam environment problem?

Thank you,