Help needed - PTS - Penetration Testing Prerequisites - Data Exfiltration Lab - Task 2

I am currently using Kali version 2021.3 with OpenVPN version 2.5.1

For this task, I started a Python HTTP server via Python with port 8080. I remotely connected to host and launched Edge to browse to my HTTP server. I have tried port 8080 and many other ports, however, I constantly get this error.

I can select “Always use this app”, but the “OK” button is always grayed out.

Any ideas what the issue is or how to resolve this?

Thank you

What file are you trying to open/download? I reckon that’s the address 172[.]16[.]XX[.]XX:8000?
Did you prepend http:// to the address jic?
If that still doesn’t work, is Internet Explorer found on the machine? If so, try with IE instead.

You did it like this?

Did you type: python -m SimpleHTTPServer port:8080?

Then you type in the bowser on target computer http://[your IP address].

You find your IP address on tap0 by running ifconfig.

Thank you for all the responses.

I was able to get it working using Internet Explorer and I did not prepend http:// in Edge, so both work now.

1 Like

Glad that worked out for you.

You can also set a share drive through rdesktop with the following flag set rdesktop <REMOTE_IP> -r disk:myshare=/path/to/your/dir

For example: If you have a directory called Tools in your home directory, the flag would be ... -r disk:share=/home/$USER/Tools

Thanks for the tip, appreciate it