Layer3 EtherChannel failed to establish neighbor adjacency

Hi INE community :raised_hand:,

I was practicing to configure Layer3 EtherChannel. Consider the following network topology, I failed to get S1 ping S2 through port channel 12.

Configurations on both switches

1. Switch S1’s configurations:

S1#show running-config
interface Port-channel12
 no switchport
 ip address 10.1.12.1 255.255.255.0
!
interface GigabitEthernet0/0
 no switchport
 no ip address
 negotiation auto
 channel-group 12 mode desirable
!
interface GigabitEthernet0/1
 no switchport
 no ip address
 negotiation auto
 channel-group 12 mode desirable
!

!-------------------------------

S1#show etherchannel 12 summary
Number of channel-groups in use: 1
Number of aggregators:           1

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
12     Po12(RD)        PAgP      Gi0/0(s)    Gi0/1(s)

!-------------------------------

S1#show interfaces status
Port      Name               Status       Vlan       Duplex  Speed Type
Gi0/2                        connected    2            auto   auto unknown
Gi0/3                        connected    2            auto   auto unknown
Gi0/0                        connected    routed       auto   auto unknown
Gi0/1                        connected    routed       auto   auto unknown
Po12                         connected    routed       auto   auto

!-------------------------------

S1#show ip route
      10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C        10.1.2.0/24 is directly connected, Vlan2
L        10.1.2.1/32 is directly connected, Vlan2
C        10.1.12.0/24 is directly connected, Port-channel12
L        10.1.12.1/32 is directly connected, Port-channel12

!-------------------------------

S1#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
GigabitEthernet0/2     unassigned      YES unset  up                    up
GigabitEthernet0/3     unassigned      YES unset  up                    up
GigabitEthernet0/0     unassigned      YES manual up                    up
GigabitEthernet0/1     unassigned      YES manual up                    up
Port-channel12         10.1.12.1       YES manual up                    up
Vlan2                  10.1.2.1        YES manual up                    up

2. Switch S2’s configurations:

S2#show running-config
interface Port-channel12
 no switchport
 ip address 10.1.12.2 255.255.255.0
!
interface GigabitEthernet0/0
 no switchport
 no ip address
 negotiation auto
 channel-group 12 mode desirable
!
interface GigabitEthernet0/1
 no switchport
 no ip address
 negotiation auto
 channel-group 12 mode desirable

!-------------------------------

S2#show etherchannel 12 summary
Number of channel-groups in use: 1
Number of aggregators:           1

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
12     Po12(RD)        PAgP      Gi0/0(s)    Gi0/1(s)

!-------------------------------

S2#show interfaces status
Port      Name               Status       Vlan       Duplex  Speed Type
Gi0/2                        connected    3            auto   auto unknown
Gi0/3                        connected    3            auto   auto unknown
Gi0/0                        connected    routed       auto   auto unknown
Gi0/1                        connected    routed       auto   auto unknown
Po12                         connected    routed       auto   auto

!-------------------------------

S2#show ip route
      10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C        10.1.3.0/24 is directly connected, Vlan3
L        10.1.3.1/32 is directly connected, Vlan3
C        10.1.12.0/24 is directly connected, Port-channel12
L        10.1.12.2/32 is directly connected, Port-channel12

!-------------------------------

S2#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
GigabitEthernet0/2     unassigned      YES unset  up                    up
GigabitEthernet0/3     unassigned      YES unset  up                    up
GigabitEthernet0/0     unassigned      YES manual up                    up
GigabitEthernet0/1     unassigned      YES manual up                    up
Port-channel12         10.1.12.2       YES manual up                    up
Vlan3                  10.1.3.1        YES manual up                    up

I’ve tried different modes of EtherChannel and some basic troubleshootings on Layer3 Etherchannel as duplex, speed, switchport mismatched but the issue is not fixed.

If anyone has any suggestion or needs more configuration details, please let me know. I really really appreciate your time for reading all these.

Thanks!

Update #1

I've tried to reload the switches, they appear to successfully form neighbor adjacency, but they still fail to ping each other

Switch S1’s etherchannel verification:

S1#show etherchannel 12 summary
Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
12     Po12(RU)        PAgP      Gi0/0(P)    Gi0/1(P)

Switch S2’s etherchannel verification:

S2#show etherchannel 12 summary
Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
12     Po12(RU)        PAgP      Gi0/0(P)    Gi0/1(P)

Debug log:

S1#ping 10.1.12.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.12.2, timeout is 2 seconds:

*Jun  7 04:10:51.199: IP: s=10.1.12.1 (local), d=10.1.12.2, len 100, local feature, Auth Proxy(16), rtype 0, forus FALSE, sendsel
*Jun  7 04:10:51.200: IP: tableid=0, s=10.1.12.1 (local), d=10.1.12.2 (Port-channel12), routed via FIB
*Jun  7 04:10:51.201: IP: s=10.1.12.1 (local), d=10.1.12.2 (Port-channel12), len 100, sending
*Jun  7 04:10:51.203: IP: s=10.1.12.1 (local), d=10.1.12.2 (Port-channel12), len 100, encapsulation failed
*Jun  7 04:10:51.440: IP: s=0.0.0.0 (Vlan2), d=255.255.255.255, len 331, input feature, MCI Check(109), rtype 0, forus FALSE, sen.
*Jun  7 04:10:51.442: IP: s=0.0.0.0 (Vlan2), d=255.255.255.255, len 331, rcvd 2
*Jun  7 04:10:51.443: IP: s=0.0.0.0 (Vlan2), d=255.255.255.255, len 331, stop process pak for forus packet
*Jun  7 04:10:53.200: IP: s=10.1.12.1 (local), d=10.1.12.2, len 100, local feature, Auth Proxy(16), rtype 0, forus FALSE, sendsel
*Jun  7 04:10:53.201: IP: tableid=0, s=10.1.12.1 (local), d=10.1.12.2 (Port-channel12), routed via FIB
*Jun  7 04:10:53.202: IP: s=10.1.12.1 (local), d=10.1.12.2 (Port-channel12), len 100, sending
*Jun  7 04:10:53.205: IP: s=10.1.12.1 (local), d=10.1.12.2 (Port-channel12), len 100, encapsulation failed.
*Jun  7 04:10:54.778: IP: s=0.0.0.0 (Vlan2), d=255.255.255.255, len 331, input feature, MCI Check(109), rtype 0, forus FALSE, sen
*Jun  7 04:10:54.779: IP: s=0.0.0.0 (Vlan2), d=255.255.255.255, len 331, rcvd 2
*Jun  7 04:10:54.780: IP: s=0.0.0.0 (Vlan2), d=255.255.255.255, len 331, stop process pak for forus packet
*Jun  7 04:10:55.199: IP: s=10.1.12.1 (local), d=10.1.12.2, len 100, local feature, Auth Proxy(16), rtype 0, forus FALSE, sendsel
*Jun  7 04:10:55.201: IP: tableid=0, s=10.1.12.1 (local), d=10.1.12.2 (Port-channel12), routed via FIB
*Jun  7 04:10:55.201: IP: s=10.1.12.1 (local), d=10.1.12.2 (Port-channel12), len 100, sending
*Jun  7 04:10:55.202: IP: s=10.1.12.1 (local), d=10.1.12.2 (Port-channel12), len 100, encapsulation failed.
*Jun  7 04:10:57.199: IP: s=10.1.12.1 (local), d=10.1.12.2, len 100, local feature, Auth Proxy(16), rtype 0, forus FALSE, sendsel
*Jun  7 04:10:57.201: IP: tableid=0, s=10.1.12.1 (local), d=10.1.12.2 (Port-channel12), routed via FIB
*Jun  7 04:10:57.201: IP: s=10.1.12.1 (local), d=10.1.12.2 (Port-channel12), len 100, sending
*Jun  7 04:10:57.203: IP: s=10.1.12.1 (local), d=10.1.12.2 (Port-channel12), len 100, encapsulation failed.
*Jun  7 04:10:58.682: IP: s=0.0.0.0 (Vlan2), d=255.255.255.255, len 331, input feature, MCI Check(109), rtype 0, forus FALSE, sen
*Jun  7 04:10:58.683: IP: s=0.0.0.0 (Vlan2), d=255.255.255.255, len 331, rcvd 2
*Jun  7 04:10:58.684: IP: s=0.0.0.0 (Vlan2), d=255.255.255.255, len 331, stop process pak for forus packet
*Jun  7 04:10:59.199: IP: s=10.1.12.1 (local), d=10.1.12.2, len 100, local feature, Auth Proxy(16), rtype 0, forus FALSE, sendsel
*Jun  7 04:10:59.201: IP: tableid=0, s=10.1.12.1 (local), d=10.1.12.2 (Port-channel12), routed via FIB
*Jun  7 04:10:59.201: IP: s=10.1.12.1 (local), d=10.1.12.2.

mac address it is not assigned to the port-channel (both S1 and S2)

S1#show interface port-channel12
Port-channel12 is up, line protocol is up (connected)
  Hardware is EtherChannel, address is 0000.0000.0000 (bia 0000.0000.0000)
  Internet address is 10.1.12.1/24
[...snip...]

Hi Cuong!
Can you share with us what type of environment you’re using to create this topology? Are you using real Cisco hardware? Packet Tracer? GNS3 with IOUvL2 switches?

What you’ve configured should work with real hardware, however, I’ve seen some glitchy behavior when it comes to using virtual switches (like GNS3 or Packet Tracer) so it’s very possible that you are experiencing a bug like that.
Keith

1 Like

Thanks for your reply,

Yes Keith, I am using IOUvL2 switches on Eve-NG. It’s very good to know that I’ve configured the switches properly. It’s all that matters!

Thanks again for your time, Keith. Enjoy your day!
Cuong