Metasploit lab eJPT problem

I have a problem in metasploit lab. When I get to the point I have to use hashdump command it fails just like the link.

Did anyone experienced something similar?

Welcome @T3igger84 to the community.
Never came across this. But check this,

  1. Verify you have the privilege to dump the hash from the target machine. Check the status by using getuid and sysinfo commands from meterpreter. Most probably, if you don’t have the sufficient/system privileges, the hashdump might fail.
  2. Try to use hashdump after executing use priv and getsystem commands. This works on older systems and might fail on newer ones. ( getsystem elevates the privilege level to root.)

Also It would be better if you can put the output of the above commands , screenshots here.

Here are some, I did like every time. Maybe I should go to older version of Kali and metasploit.

Hi @T3igger84 , i just tried to replicate the issue with the same metasploit lab, worked fine and was able to run hashdump without any issues.
The framework/console version i’m running was 6.0.49-dev. Then i updated it to the latest version 6.0.53-dev. Still no issues. Able to dump the hashes.

Don’t know, but migrating the service to another in meterpreter could help?? or perform a full upgrade sudo apt update -y && apt upgrade -y && apt dist-upgrade and then try again.

1 Like

Hi jaa. I tried the full update, it didn’t work and I tried to migrate before and it didn’t work. I went back to kali 2020.4 new vm in virtualbox and it worked. I managed to hashdump and I finished the box finally. Thanks for the help.


Update your Kali. Might need to give your VM more memory.

Recommended by Kali:
Kali settings for vitual PC:
→ Should be a minimun of 2gb of Ram

I run 8gb RAM with 100gb space and 3 cores. No issues.