Network type mismatch

Hi everyone
R2–f0/1—R3
R2#show running-config interface fastEthernet 0/1
interface FastEthernet0/1
ip address 10.1.23.2 255.255.255.0
ip ospf network point-to-multipoint
ip ospf 1 area 0

R3#show running-config interface fastEthernet 0/1
interface FastEthernet0/1
ip address 10.1.23.3 255.255.255.0
ip ospf network point-to-multipoint non-broadcast
ip ospf 1 area 0

R3#show running-config | section router ospf
router ospf 1
router-id 0.0.0.3

the neighbor adjacency is up between R2 and R3 ,why ?

R3 should sending hellos as unicast

first of all, i didn`t specify the neighbor statement on R3
also,one side is sending a unicast dst,and the other side is sending a multicast dst

how could that make both sides forming ospf adjacency ?