The System Security lab get stuck continuously

,

Hello everyone,

I am trying to work with the System Security lab.

Every time I connect via rdp the server ends up closing the connection every few minutes, sometimes it takes about 3 minutes, but usually after a few seconds it closes the connection.

I have tried connecting with remmina, xfreerdp and the native windows client and the same thing always happens.

I leave information about my system in case someone can give me a hand:

cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=22.04
DISTRIB_CODENAME=jammy
DISTRIB_DESCRIPTION=“Ubuntu 22.04.1 LTS”

uname -a
Linux 5.15.0-52-generic #58-Ubuntu SMP Thu Oct 13 08:03:55 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux

xfreerdp --version
This is FreeRDP version 2.7.0 (2.7.0)

Remmina: 1.4.27

These are the parameters I use to connect:
xfreerdp /v:172.16.5.66 /u:Student /p:XXXXXX

and this is the error:

[19:06:50:103] [8644:8645] [INFO][com.freerdp.core] - ERRINFO_DECRYPT_FAILED (0x00001192):(a) Decryption using Standard RDP Security mechanisms (section 5.3.6) failed.
(b) Session key creation using Standard RDP Security mechanisms (section 5.3.5) failed.
[19:06:50:103] [8644:8645] [ERROR][com.freerdp.core] - rdp_set_error_info:freerdp_set_last_error_ex ERRINFO_DECRYPT_FAILED [0x00011192]
[19:06:50:103] [8644:8645] [ERROR][com.freerdp.core.transport] - BIO_read returned a system error 104: Connection reset by peer

It seems to be a problem with rdp protocol versions in such old versions of windows.

I have tried with the rdesktop client and it seems to work now.