WebAppLabs - Web Application Attacks SQLMAP Time Out

Has any one had luck with the new web VM format on this lab?

I absolutely hate that I don’t get to practice with my own machine and tools anymore when the ecppt exam format still hasn’t changed to follow suit but that’s a whole other issue.

Anyways, I’m getting error:

connection timed out to the target url

3306 is open and there doesn’t seem to be any sort of UFW on the host in the way in the VM

The below supplied answer:

sqlmap -u “http://demo.ine.local/index.php?page=user-info.php&username=test&password=test&user-info-php-submit-button=View+Account+Details” --cookie “PHPSESSID=gotu3qj422pmksv4ubtmjbmmo5; showhints=1” -p username

Does not work for me.

Have also tried removing the parameter switch and the cookie (to let sqlmap set it automatically)
Have also tried various combinations with



–forms --crawl=2 from the root link

One time the below ran

sqlmap -u “http://demo.ine.local/index.php?page=user-info.php?page=user-info.php&username=test&password=test” -p username

but then said

"GET parameter 'username does not seem to be injectable

Did you update with your own cookie?
It is injectable. Requires authentication, thus the cookie, like it says in the solution.

Yes, multiple times, and with and without Burp to get the cookie (used inspect in firefox) - It’s the same issue. Demo.ine.local also stops loading on any link after SQLmap times out sometimes

you might want to ping demo.ine.local if it’s starting to timeout. There’s a good chance you knocked it over with sqlmap. I haven’t had that problem, but it does happen. If that does happen, restart the lab environment and you’ll be back up and running.

I restarted the lab multiple times as well the other day. Trying again today with a consistent ping running and SQLmap connection still throws time out to target URL error with low latency and no packet loss.

133 received, 0% packet loss, time 135162ms
rtt min/avg/max/mdev = 0.049/0.080/0.115/0.014 ms

Site is now no longer loading pages again but is still pingable without loss. (No BURP isn’t on and intercepting still)
Resetting the lab will fix the demo.ine.local site but the issue I am experiencing persists.

can you get some screenshots of what you’re doing. I don’t recommend the constant ping.


Ok, looks like you have it all as prescribed. I just replicated myself. Seems like the VM is having issues. Reported to our lab team.
Sorry that this happened. Thank you for letting us know about it.

1 Like

Confirmed working after lab fix.

Was not prompted for full path disclosure or brute for search when gaining os-shell as listed in the lab answers but everything is functional now.

Thank you