32bitftp says its passed the 30 day trial period and will not run without a license?

, ,

In the System Security Lab 1, I am trying to follow along with the buffer overflow of Vulnerable 32bitFTP client, however when I run the FTP application it says the trial period has expired and will not allow me the full functionality needed to try to “remote” connect to the python buffer overflow code. Has anyone else had this issue? and if so how did you fix it?

troubleshooting so far:

  1. tried installing to the desktop to see if it would be treated as a new instance of the application
  2. did an uninstall of the 32bitFTP application and reinstalled again

Still getting the trial period over warning and unable to use the 32bitFTP application to practice the buffer overflow…ANY help would be greatly appreciated!

This probably isn’t the answer you’re looking for but you would probably just be better off configuring your own windows VM already to practice buffer overflows from your linux host. It might helpful to have something like that in place already prior to writing the ecppt anyways…

Set the date of the windows box to something like 05/09/2017 and it will work.